Back to overview
Degraded
Some users are experiencing issues accessing Observe
Jul 11 at 08:58am CDT
Affected services
Observe Platform
Resolved
Jul 11 at 09:41am CDT
We have identified the issue and it is now resolved.
Affected services
Created
Jul 11 at 08:58am CDT
Some users are experiencing issues accessing the Observe platform. Our engineering team is looking into this and we hope to have it resolved asap.
Affected services